Find a string Hacker Rank Solution – Queslers

Problem: Find a string Hacker Rank Solution

In this challenge, the user enters a string and a substring. You have to print the number of times that the substring occurs in the given string. String traversal will take place from left to right, not from right to left.

NOTE: String letters are case-sensitive.

Input Format

The first line of input contains the original string. The next line contains the substring.

Constraints

1 <= len(string) <= 200

Each character in the string is an ascii character.

Output Format

Output the integer number indicating the total number of occurrences of the substring in the original string.

Sample Input

ABCDCDC
CDC

Sample Output 

2

Concept

There are a couple of new concepts:

In Python, the length of a string is found by the function len(s), where s is the string.

To traverse through the length of a string, use a for loop:

for i in range(0, len(s)):
    print (s[i])

A range function is used to loop over some length:

range (0, 5)

Here, the range loops over 0 to 45 is excluded.

Find a string Hacker Rank Solution in Python 2

a,b=(raw_input() for i in range(2))
cnt=0
for i in range(len(a)-len(b)+1):
	if a[i:i+len(b)]==b:
		cnt+=1
print cnt

Find a string Hacker Rank Solution in Python 3

def count_substring(string, sub_string):
    count = 0
    for i in range(0, len(string)-len(sub_string)+1):
        l = i
        for j in range(0, len(sub_string)):
            if string[l] == sub_string[j]:
                l +=1
                if j == len(sub_string)-1:
                    count = count + 1
                else:
                    continue
            else:
                break
            
    return count

Find a string Hacker Rank Solution in pypy

# Enter your code here. Read input from STDIN. Print output to STDOUT
s=raw_input()
d=len(s)
ss=raw_input()
dd=len(ss)
c=0

for i in range(d-dd+1):

    if s[i:i+dd] == ss:
        c+=1
print c

Find a string Hacker Rank Solution in pypy3

#def count_substrings(string, sub_string):
string=str(input())
sub_string=str(input())
#print(string)
#print(sub_string)
count=0
for i in range(0,len(string)):
    str_i=string[i:i+len(sub_string)]
    #print(str_i)    
    if str_i ==sub_string:
        count=count+1
print(count)
#return 
Find a string Hacker Rank Solution Review:

In our experience, we suggest you solve this Find a string Hacker Rank Solution and gain some new skills from Professionals completely free and we assure you will be worth it.

Find a string Problem is available on Hacker Rank for Free, if you are stuck anywhere between compilation, just visit Queslers to get all Hacker Rank Solution

Conclusion:

I hope this Find a string Hacker Rank Solution would be useful for you to learn something new from this problem. If it helped you then don’t forget to bookmark our site for more Hacker Rank, Leetcode, Codechef, Codeforce Solution.

This Problem is intended for audiences of all experiences who are interested in learning about Data Science in a business context; there are no prerequisites.

Keep Learning!

More Hacker Rank Problem & Solutions >>

Iterables and Iterators Hacker Rank Solution

Triangle Quest 2 Hacker Rank Solution 

Piling Up Hacker Rank Solution

set.union() Operators Hacker Rank Solution 

Company Logo Hacker Rank Solution

Set .intersection() Hacker Rank Solution

Leave a Reply

Your email address will not be published. Required fields are marked *