Physical Address

304 North Cardinal St.
Dorchester Center, MA 02124

Find Angle MBC Hacker Rank Solution – Queslers

Problem: Find Angle MBC Hacker Rank Solution

Task

ABC is a right triangle, 90o at B.
Therefore, angle ABC = 90o.
Point M is the midpoint of hypotenuse AC.

You are given the lengths AB and BC.
Your task is to find angle MBC in degrees.

Input Format :

The first line contains the length of side AB.
The second line contains the length of side BC.

Constraints :

  • 0 < AB <= 100
  • 0 < BC <= 100
  • Lengths AB and BC are natural numbers.

Output Format :

Output MBC in degrees.
Note: Round the angle to the nearest integer.

Examples :
If angle is 56.5000001°, then output 57°.
If angle is 56.5000000°, then output 57°.
If angle is 56.4999999°, then output 56°.

Sample Input :

10
10

Sample Output :

45°

Find Angle MBC Hacker Rank Solution in python 2

# Enter your code here. Read input from STDIN. Print output to STDOUT
import math
ab = float(raw_input())
bc = float(raw_input())
tang = ab / bc
rad = math.atan(tang)
print '{}°'.format(int(round(math.degrees(rad))))

Find Angle MBC Hacker Rank Solution in python 3

# Enter your code here. Read input from STDIN. Print output to STDOUT
import math
a = int(input())
b = int(input())
M = math.sqrt(a**2+b**2)
theta = math.acos(b/M )
print(str(round(math.degrees(theta)))+'°')

Find Angle MBC Hacker Rank Solution in pypy

# Enter your code here. Read input from STDIN. Print output to STDOUT
import math

n = input()
m = input()

print str(int(round(math.degrees(math.atan2(n,m))))) + u'\N{DEGREE SIGN}'

Find Angle MBC Hacker Rank Solution in pypy 3

# Enter your code here. Read input from STDIN. Print output to STDOUT
import math
AB = float(input())
BC = float(input())

print(str(int(round(math.degrees(math.atan2(AB, BC)))))+'°')

Find Angle MBC Hacker Rank Solution Review:

In our experience, we suggest you solve this Find Angle MBC Hacker Rank Solution and gain some new skills from Professionals completely free and we assure you will be worth it.

Find Angle MBC problem is available on Hacker Rank for Free, if you are stuck anywhere between a compilation, just visit Queslers to get Find Angle MBC Hacker Rank Solution

Conclusion:

I hope this Find Angle MBC Hacker Rank Solution would be useful for you to learn something new from this problem. If it helped you then don’t forget to bookmark our site for more Hacker Rank, Leetcode, Codechef, Codeforce Solution.

This Problem is intended for audiences of all experiences who are interested in learning Programming in a business context; there are no prerequisites.

Keep Learning!

More Hacker Rank Problem & Solutions >>

Time Delta Hacker Rank Solution

Calendar Module Hacker Rank Solution

Introduction to Sets Hacker Rank solution

Polar Coordinates Hacker Rank Solution 

Magical Sequence CodeChef Solution

Leave a Reply

Your email address will not be published. Required fields are marked *