Physical Address

304 North Cardinal St.
Dorchester Center, MA 02124

itertools.product() Hacker Rank Solution – Queslers

Problem: itertools.product() Hacker Rank Solution

This tool computes the cartesian product of input iterables.

It is equivalent to nested for-loops.
For example, product(A, B) returns the same as ((x,y) for x in A for y in B).

Sample Code :

>>> from itertools import product
>>>
>>> print list(product([1,2,3],repeat = 2))
[(1, 1), (1, 2), (1, 3), (2, 1), (2, 2), (2, 3), (3, 1), (3, 2), (3, 3)]
>>>
>>> print list(product([1,2,3],[3,4]))
[(1, 3), (1, 4), (2, 3), (2, 4), (3, 3), (3, 4)]
>>>
>>> A = [[1,2,3],[3,4,5]]
>>> print list(product(*A))
[(1, 3), (1, 4), (1, 5), (2, 3), (2, 4), (2, 5), (3, 3), (3, 4), (3, 5)]
>>>
>>> B = [[1,2,3],[3,4,5],[7,8]]
>>> print list(product(*B))
[(1, 3, 7), (1, 3, 8), (1, 4, 7), (1, 4, 8), (1, 5, 7), (1, 5, 8), (2, 3, 7), (2, 3, 8), (2, 4, 7), (2, 4, 8), (2, 5, 7), (2, 5, 8), (3, 3, 7), (3, 3, 8), (3, 4, 7), (3, 4, 8), (3, 5, 7), (3, 5, 8)]

Task :

You are given a two lists A and B. Your task is to compute their cartesian product AXB.Example :

A = [1, 2]
B = [3, 4]

AxB = [(1, 3), (1, 4), (2, 3), (2, 4)]

Note: A and B are sorted lists, and the cartesian product’s tuples should be output in sorted order.

Input Format :

The first line contains the space separated elements of list A.
The second line contains the space separated elements of list B.
Both lists have no duplicate integer elements.

Constraints :

  • 0 < A < 30
  • 0 < B < 30

Output Format :

Output the space separated tuples of the cartesian product.

Sample Input :

 1 2
 3 4

Sample Output :

(1, 3) (1, 4) (2, 3) (2, 4)

itertools.product() Hacker Rank Solution in Python 2

from itertools import product

A = map(int,raw_input().split())
B = map(int,raw_input().split())
print " ".join(str(k) for k in product(A,B))

itertools.product() Hacker Rank Solution in Python 3

# Enter your code here. Read input from STDIN. Print output to STDOUT

from itertools import product
a = map(int, input().split())
b = map(int, input().split())

print(*product(a, b))

itertools.product() Hacker Rank Solution in pypy

from itertools import product
flist = map(int, raw_input().split())
slist = map(int, raw_input().split())

for item in product(flist, slist):
    print tuple(item), 

itertools.product() Hacker Rank Solution in pypy3

import itertools
# Enter your code here. Read input from STDIN. Print output to STDOUT
A = list(map(int,input().split()))
B = list(map(int,input().split()))

p = list(itertools.product(A,B))
print(" ".join(map(str,p)))
itertools.product() Hacker Rank Solution Review:

In our experience, we suggest you solve this itertools.product() Hacker Rank Solution and gain some new skills from Professionals completely free and we assure you will be worth it.

itertools.product() problem is available on Hacker Rank for Free, if you are stuck anywhere between compilation, just visit Queslers to get all Hacker Rank Solution

Conclusion:

I hope this itertools.product() Hacker Rank Solution would be useful for you to learn something new from this problem. If it helped you then don’t forget to bookmark our site for more Hacker Rank, Leetcode, Codechef, Codeforce Solution.

This Problem is intended for audiences of all experiences who are interested in learning about Data Science in a business context; there are no prerequisites.

Keep Learning!

More Hacker Rank Problem & Solutions >>

Text Alignment Hacker Rank solution

String validators Hacker Rank Solution

Staircase Hacker Rank Solution

A Very Big Sum Hacker Rank Solution

Diagonal Difference Hacker Rank Solution

Leave a Reply

Your email address will not be published. Required fields are marked *