Physical Address

304 North Cardinal St.
Dorchester Center, MA 02124

Set .add() Hacker Rank Solution – Queslers

Problem: Set .add() Hacker Rank Solution

If we want to add a single element to an existing set, we can use the .add() operation.
It adds the element to the set and returns ‘None’.
Example :

>>> s = set('HackerRank')
>>> s.add('H')
>>> print s
set(['a', 'c', 'e', 'H', 'k', 'n', 'r', 'R'])
>>> print s.add('HackerRank')
None
>>> print s
set(['a', 'c', 'e', 'HackerRank', 'H', 'k', 'n', 'r', 'R'])

Task :

Apply your knowledge of the .add() operation to help your friend Rupal.
Rupal has a huge collection of country stamps. She decided to count the total number of distinct country stamps in her collection. She asked for your help. You pick the stamps one by one from a stack of N country stamps.
Find the total number of distinct country stamps.

Input Format :

The first line contains an integer N, the total number of country stamps.
The next N lines contains the name of the country where the stamp is from.

Constraints :

  • 0 < N < 1000

Output Format :

Output the total number of distinct country stamps on a single line.

Sample Input :

7
UK
China
USA
France
New Zealand
UK
France 

Sample Output :

5

Explanation :

UK and France repeat twice. Hence, the total number of distinct country stamps is 5 (five).

Set .add() Hacker Rank Solution in python 2

n = int(raw_input())
stamp = set()
for i in range(n):
  stamp.add(raw_input())
print len(stamp)

Set .add() Hacker Rank Solution in python 3

# Enter your code here. Read input from STDIN. Print output to STDOUT
a = set()
[a.add(input()) for _ in range(int(input()))]
print(len(a))

Set .add() Hacker Rank Solution in pypy

n = int(raw_input())
estampas = [raw_input() for i in range(n)]

print len(set(estampas))

Set .add() Hacker Rank Solution in pypy 3

# Enter your code here. Read input from STDIN. Print output to STDOUT
num  = int(input())
country = set([])
for i in range(num):
    country.add(input())
print(len(list(country)))
Set .add() Hacker Rank Solution Review:

In our experience, we suggest you solve this Set .add() Hacker Rank Solution and gain some new skills from Professionals completely free and we assure you will be worth it.

Set .add() problem is available on Hacker Rank for Free, if you are stuck anywhere between a compilation, just visit Queslers to get Set .add() Hacker Rank Solution

Conclusion:

I hope this Set .add() Hacker Rank Solution would be useful for you to learn something new from this problem. If it helped you then don’t forget to bookmark our site for more Hacker Rank, Leetcode, Codechef, Codeforce Solution.

This Problem is intended for audiences of all experiences who are interested in learning Programming in a business context; there are no prerequisites.

Keep Learning!

More Hacker Rank Problem & Solutions >>

Staircase Hacker Rank Solution

A Very Big Sum Hacker Rank Solution

Diagonal Difference Hacker Rank Solution

Nested Lists Hacker Rank Solution

Lists Hacker Rank Solution

Leave a Reply

Your email address will not be published. Required fields are marked *