Physical Address

304 North Cardinal St.
Dorchester Center, MA 02124

String Validators Hacker Rank Solution – Queslers

Problem: String Validators Hacker Rank Solution

You are given a string . Your task is to find out if the string  contains: alphanumeric characters, alphabetical characters, digits, lowercase and uppercase characters.

Input Format

A single line containing a string .

Output Format

In the first line, print True if  has any alphanumeric characters. Otherwise, print False.

In the second line, print True if  has any alphabetical characters. Otherwise, print False.

In the third line, print True if  has any digits. Otherwise, print False.

In the fourth line, print True if  has any lowercase characters. Otherwise, print False.

In the fifth line, print True if  has any uppercase characters. Otherwise, print False.

Sample Input

qA2

Sample Output

True
True
True
True
True

String Validators Hacker Rank Solution in Python 2

S = raw_input()
print True if any(k in "0123456789" or k.lower() in "abcdefghijklmnopqrstuvwxyz" for k in S) else False
print True if any(k.lower() in "abcdefghijklmnopqrstuvwxyz" for k in S) else False
print True if any(k in "0123456789" for k in S) else False
print True if any(k in "abcdefghijklmnopqrstuvwxyz" for k in S) else False
print True if any(k in "ABCDEFGHIJKLMNOPQRSTUVWXYZ" for k in S) else False

String Validators Hacker Rank Solution in Python 3

if __name__ == '__main__':
    s = input()
    print(any(a.isalnum() for a in s) )
    print(any(a.isalpha() for a in s) )
    print(any(a.isdigit() for a in s) )
    print(any(a.islower() for a in s) )
    print(any(a.isupper() for a in s) )

String Validators Hacker Rank Solution in pypy

# Enter your code here. Read input from STDIN. Print output to STDOUT
S=raw_input()
a=0
for i in range(len(S)):
    if S[i].isalnum():
         a+=1
if a>0:
    print 'True'
else:
    print 'False'

a=0
for i in range(len(S)):
    if S[i].isalpha():
         a+=1
if a>0:
    print 'True'
else:
    print 'False'
    
a=0
for i in range(len(S)):
    if S[i].isdigit():
         a+=1
if a>0:
    print 'True'
else:
    print 'False'
    
a=0
for i in range(len(S)):
    if S[i].islower():
         a+=1
if a>0:
    print 'True'
else:
    print 'False'
    
a=0
for i in range(len(S)):
    if S[i].isupper():
         a+=1
if a>0:
    print 'True'
else:
    print 'False'

String Validators Hacker Rank Solution in pypy3

if __name__ == '__main__':
    s = input()
    print(any(c.isalnum() for c in s))
    print(any(c.isalpha() for c in s))
    print(any(c.isdigit() for c in s))
    print(any(c.islower() for c in s))
    print(any(c.isupper() for c in s))
String Validators Hacker Rank Solution Review:

In our experience, we suggest you solve this String Validators Hacker Rank Solution and gain some new skills from Professionals completely free and we assure you will be worth it.

String Validators Problem is available on Hacker Rank for Free, if you are stuck anywhere between compilation, just visit Queslers to get all Hacker Rank Solution

Conclusion:

I hope this String Validators Hacker Rank Solution would be useful for you to learn something new from this problem. If it helped you then don’t forget to bookmark our site for more Hacker Rank, Leetcode, Codechef, Codeforce Solution.

This Problem is intended for audiences of all experiences who are interested in learning about Data Science in a business context; there are no prerequisites.

Keep Learning!

More Hacker Rank Problem & Solutions >>

Text Alignment Hacker Rank solution

String validators Hacker Rank Solution

Staircase Hacker Rank Solution

A Very Big Sum Hacker Rank Solution

Diagonal Difference Hacker Rank Solution

Leave a Reply

Your email address will not be published. Required fields are marked *