Physical Address

304 North Cardinal St.
Dorchester Center, MA 02124

The Minion Game Hacker Rank Solution – Queslers

Problem: The Minion Game Hacker Rank Solution

Task

Kevin and Stuart want to play the ‘The Minion Game’.

Game Rules

Both players are given the same string, S.

Both players have to make substrings using the letters of the string S.

Stuart has to make words starting with consonants.

Kevin has to make words starting with vowels.

The game ends when both players have made all possible substrings.

Scoring

A player gets +1 point for each occurrence of the substring in the string S.

For Example

String S = BANANA
Kevin's vowel beginning word = ANA
Here, ANA occurs twice in BANANA. Hence, Kevin will get 2 Points.

Your task is to determine the winner of the game and their score.

Input Format

A single line of input containing the string S.

Note: The string S will contain only uppercase letters: [A – Z].

Constraints

0 <= len(S) <= 10^6

Output Format

Print one line: the name of the winner and their score separated by a space.
If the game is a draw, print Draw.

Sample Input

BANANA

Sample Output

Stuart 12

The Minion Game Hacker Rank Solution in Python 2

# Enter your code here. Read input from STDIN. Print output to STDOUT
vowels = ['A', 'E', 'I', 'O', 'U']
s = raw_input()
a = 0
b = 0
for i, c in enumerate(s):
    if c in vowels:
        b += len(s) - i
    else:
        a += len(s) - i
        
if a == b:
    print "Draw"
elif a > b:
    print 'Stuart {}'.format(a)
else:
    print 'Kevin {}'.format(b)

The Minion Game Hacker Rank Solution in Python 3

def minion_game(string):
    vowels = 'AEIOU'
    Stuart_score, Kevin_score = 0, 0
    length = len(string)
    for start_idx in range(length):
        score = length - start_idx
        if string[start_idx] in vowels:
            Kevin_score += score
        else:
            Stuart_score += score
    if Stuart_score == Kevin_score:
        print('Draw')
    if Stuart_score > Kevin_score:
        print('Stuart {}'.format(Stuart_score))
    if Stuart_score < Kevin_score:
        print('Kevin {}'.format(Kevin_score))

The Minion Game Hacker Rank Solution in pypy

# Enter your code here. Read input from STDIN. Print output to STDOUT

input_string = raw_input()

vowels = ['A','E','I','O','U']

Kevin_score = 0
Stuart_score = 0

for i in range(len(input_string)):
    if input_string[i] in vowels:
        Kevin_score = Kevin_score + (len(input_string) - i)
    if input_string[i] not in vowels:
        Stuart_score = Stuart_score + (len(input_string) - i)
        
if Kevin_score == Stuart_score:
    print "Draw"
if Kevin_score > Stuart_score:
    print "Kevin",Kevin_score
if Kevin_score < Stuart_score:
    print "Stuart",Stuart_score
    

The Minion Game Hacker Rank Solution in pypy3

# Enter your code here. Read input from STDIN. Print output to STDOUT
s=input()
vv='AEIOU'
l=len(s)
c=0
v=0
for i in range(l):
    if s[i] in vv:
        v+=l-i
    else:
        c+=l-i
if c>v:
    print ('Stuart',c)
elif c==v:
    print ("Draw")
else:
    print ('Kevin',v)
The Minion Game Hacker Rank Solution Review:

In our experience, we suggest you solve this The Minion Game Hacker Rank Solution and gain some new skills from Professionals completely free and we assure you will be worth it.

The Minion Game Problem is available on Hacker Rank for Free, if you are stuck anywhere between compilation, just visit Queslers to get all Hacker Rank Solution

Conclusion:

I hope this The Minion Game Hacker Rank Solution would be useful for you to learn something new from this problem. If it helped you then don’t forget to bookmark our site for more Hacker Rank, Leetcode, Codechef, Codeforce Solution.

This Problem is intended for audiences of all experiences who are interested in learning about Data Science in a business context; there are no prerequisites.

Keep Learning!

More Hacker Rank Problem & Solutions >>

itertools.product() Hacker Rank Solution

String Validators Hacker Rank Solution

Text Alignment Hacker Rank solution

String validators Hacker Rank Solution

Staircase Hacker Rank Solution

Leave a Reply

Your email address will not be published. Required fields are marked *